CVE Catalog

CVE-2026-41636

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.45%

39th percentile - higher than 39% of all known CVEs

Summary

Apache Thrift Node.js bindings before version 0.23.0 contain an uncontrolled recursion vulnerability. This may lead to resource exhaustion or application crash when processing specially crafted data.

Risk Assessment

Applications using Apache Thrift for Node.js may crash or become unavailable due to a denial-of-service attack. The risk affects service availability.

Recommendation

Upgrade Apache Thrift to version 0.23.0, which fixes this vulnerability.

Other vulnerabilities in Apache Thrift

See all
Original NVD description (English source)

Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS