CVE-2026-40888
MediumCVSS 6.5Exploitation Probability (EPSS)
Low risk14th percentile - higher than 14% of all known CVEs
Summary
Frappe HR prior to versions 15.58.1 and 16.4.1 allows an authenticated user with default role to access unauthorized information by exploiting a certain API endpoint. Versions 15.58.1 and 16.4.1 contain a patch.
Risk Assessment
A user with basic privileges can access data they should not have access to, potentially leading to a breach of HR information confidentiality. This may result in leakage of employees' personal data.
Recommendation
Update Frappe HR to version 15.58.1 or 16.4.1 (or later). No known workarounds are available, so updating is the only solution.
Other vulnerabilities in Frappe HR
See all- CVE-2026-64862Medium
Frappe HR is an open-source human resources management solution (HRMS). Prior to 15.58.3 and 16.4.3, HRMS PWA API endpoints for employee data do not consistently authorize employee-specific PWA API requests. An authenticated user can request records associated with another employee.
- CVE-2026-55796Medium
Frappe HR is an open-source human resources management solution (HRMS). Prior to 15.60.3 and 16.7.1, the Salary Payments via ECS report constructs report conditions with unsafe SQL string interpolation. An authenticated HR user supplies crafted Salary Payments via ECS report filter values.
- CVE-2026-108733Medium
Frappe HR (hrms) before 16.11.0, including all 14.x and 15.x releases through 15.64.3, contains a missing authorization vulnerability in the whitelisted expire_allocation method that allows authenticated users to expire any leave allocation. Attackers without HR roles can name another employee's Leave Allocation in a POST request to zero its allocated leaves and wipe that employee's remaining leave balance.
- CVE-2026-108732Medium
Frappe HR (hrms) before 16.11.0, including all 14.x and 15.x releases through 15.64.3, contains a missing authorization vulnerability in the whitelisted get_account_and_amount method that lets authenticated users read payroll amounts. Attackers without HR roles can call the method over /api/method with enumerable Salary Slip or claim document names to disclose other employees' net pay and loan, advance, and claim balances.
- CVE-2026-101006Medium
A vulnerability was found in Frappe HR up to 16.15.0, affecting the get_expense_claims/get_shift_requests/get_attendance_requests functions in hrms/api/__init__.py (Permission Validation component). Manipulation of the employee argument leads to incorrect authorization. The attack can be launched remotely; the vendor confirmed the issue has already been fixed.
- CVE-2026-54524High
In Frappe HR (an open-source human resources management solution) before version 16.7.0, an authenticated user with the HR User role can inject SQL through filters in the Salary Payments Based on Payment Mode report. In hrms/payroll/report/salary_payments_based_on_payment_mode/salary_payments_based_on_payment_mode.py, get_conditions constructs filter clauses from user-controlled values and get_data incorporates those clauses into a string-formatted SQL query, allowing extraction of arbitrary database data. The issue is fixed in 16.7.0.
- CVE-2026-41320Medium
Frappe HR (HRMS) versions prior to 15.54.0 and 14.38.1 contain a SQL injection vulnerability via a specially crafted request to a certain endpoint. An attacker can exploit this to extract information they wouldn't otherwise be able to access. Versions 15.54.0 and 14.38.1 contain a patch; no known workarounds are available.
- CVE-2026-40889Medium
Frappe HR is an open-source human resources management solution (HRMS). Prior to versions 15.58.2 and 16.4.2, authenticated users can access unauthorized files by exploiting a certain API endpoint. Versions 15.58.2 and 16.4.2 contain a patch. No known workarounds are available.
Original NVD description (English source)
Frappe HR is an open-source human resources management solution (HRMS). Prior to versions 15.58.1 and 16.4.1, an authenticated user with default role can access unauthorized information by exploiting certain api endpoint. Versions 15.58.1 and 16.4.1 contain a patch. No known workarounds are available.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

