CVE-2026-35487
MediumCVSS 5.3Exploitation Probability (EPSS)
Low risk18th percentile - higher than 18% of all known CVEs
Summary
text-generation-webui prior to 4.3 contains an unauthenticated path traversal vulnerability in load_prompt() that allows reading any .txt file on the server filesystem. The file content is returned verbatim in the API response.
Risk Assessment
An unauthenticated attacker can read sensitive text files from the server, potentially leading to information disclosure. The vulnerability is easily exploitable remotely.
Recommendation
Update text-generation-webui to version 4.3 or later. Restrict network access to the interface if immediate update is not possible.
Other vulnerabilities in text-generation-webui
See all- CVE-2026-35484Medium
text-generation-webui before 4.3 has an unauthenticated path traversal vulnerability in load_preset() that allows reading any .yaml file on the server filesystem. Parsed YAML key-value pairs (including passwords, API keys, connection strings) are returned in the API response. Fixed in 4.3.
- CVE-2026-35483Medium
text-generation-webui prior to 4.3 has an unauthenticated path traversal vulnerability in load_template() allowing reading files with .jinja, .jinja2, .yaml, or .yml extensions from anywhere on the server filesystem. For .jinja files content is returned verbatim; for .yaml a parsed key is extracted. Fixed in 4.3.
- CVE-2025-62364Medium
In text-generation-webui versions through 3.13, a Local File Inclusion vulnerability exists in the character picture upload feature. An attacker can upload a text file containing a symbolic link to an arbitrary file path, allowing an unauthenticated attacker to read sensitive files on the server.
Original NVD description (English source)
text-generation-webui is an open-source web interface for running Large Language Models. Prior to 4.3, an unauthenticated path traversal vulnerability in load_prompt() allows reading any .txt file on the server filesystem. The file content is returned verbatim in the API response. This vulnerability is fixed in 4.3.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

