CVE-2026-35194
HighCVSS 8.1Exploitation Probability (EPSS)
Low risk32th percentile - higher than 32% of all known CVEs
Summary
Apache Flink versions 1.15.0 through 1.20.x and 2.0.0 through 2.x have a code injection vulnerability in SQL code generation. Authenticated users with query submission privileges can execute arbitrary code on TaskManagers via maliciously crafted SQL queries.
Risk Assessment
This vulnerability may lead to unauthorized code execution, posing a serious threat to the integrity and security of the system. Attackers can exploit this flaw to gain control over the system.
Recommendation
It is recommended to upgrade to versions 1.20.4, 2.0.2, 2.1.2, or 2.2.1, which fix this issue.
Other vulnerabilities in Apache Flink
Original NVD description (English source)
Code injection in SQL code generation in Apache Flink 1.15.0 through 1.20.x and 2.0.0 through 2.x allows authenticated users with query submission privileges to execute arbitrary code on TaskManagers via maliciously crafted SQL queries. The vulnerability affects JSON functions (1.15.0+) and LIKE expressions with ESCAPE clauses (1.17.0+). User-controlled strings are interpolated into generated Java code without proper escaping, allowing attackers to break out of string literals and inject arbitrary expressions. Users are recommended to upgrade to either version 1.20.4, 2.0.2, 2.1.2 or 2.2.1, which fixes this issue.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

