CVE Catalog

CVE-2026-33521

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Summary

There is a denial of service vulnerability in Esri ArcGIS Server versions 12.0 and prior that may allow a remote, unauthenticated attacker to supply crafted requests that may, under exceptional circumstances, consume all available worker threads and deny service to users.

Risk Assessment

This may lead to unavailability of GIS services for the organization's users.

Recommendation

Update ArcGIS Server to a patched version (12.0, 11.5, 11.3, or 11.1) and consider upgrading unsupported versions.

Other vulnerabilities in Esri ArcGIS Server

See all
Original NVD description (English source)

There is s denial of service vulnerability in Esri ArcGIS Server versions 12.0 and prior that may allow a remote, unauthenticated attacker to supply crafted requests that may, under exceptional circumstances, consume all available worker threads and deny service to users. A patch is provided for ArcGIS Server software in General Availability and Extended support status, which includes versions 12.0, 11.5, 11.3, and 11.1. Other versions are in mature or retired status, which are not patch eligible. Users working with unlisted versions are advised to upgrade and apply the patch.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS