CVE Catalog

CVE-2026-32271

HighCVSS 7.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.48%

41th percentile - higher than 41% of all known CVEs

Summary

Craft Commerce versions 4.0.0 through 4.10.2 and 5.0.0 through 5.5.4 contain an SQL injection vulnerability in the TotalRevenue widget that allows any authenticated control panel user to achieve remote code execution through a four-step exploitation chain. The attack exploits unsanitized widget settings interpolated into SQL expressions and PDO's default multi-statement query support to inject a maliciously serialized PHP object into the queue table, leading to a PHP webshell written to the server's webroot.

Risk Assessment

An authenticated control panel user can execute arbitrary commands as the PHP process user, leading to full server compromise. The chain requires only three HTTP requests and no administrative privileges.

Recommendation

Update Craft Commerce to version 4.10.3 or 5.5.5, which fix the vulnerability. Until updated, restrict access to the control panel and monitor for unusual queue jobs.

Other vulnerabilities in Craft Commerce

See all
Original NVD description (English source)

Craft Commerce is an ecommerce platform for Craft CMS. In versions 4.0.0 through 4.10.2 and 5.0.0 through 5.5.4, there is an SQL injection vulnerability in the Commerce TotalRevenue widget which allows any authenticated control panel user to achieve remote code execution through a four-step exploitation chain. The attack exploits unsanitized widget settings interpolated into SQL expressions, combined with PDO's default multi-statement query support, to inject a maliciously serialized PHP object into the queue table. When the queue consumer processes the injected job, the unrestricted unserialize() call in yii2-queue instantiates a GuzzleHttp FileCookieJar gadget chain whose __destruct() method writes a PHP webshell to the server's webroot. The complete chain requires only three HTTP requests, no administrative privileges, and results in arbitrary command execution as the PHP process user, with queue processing triggered via an unauthenticated endpoint. This issue has been fixed in versions 4.10.3 and 5.5.5.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS