CVE Catalog

CVE-2026-26958

LowCVSS 1.7
Published: Updated: Translated: NVD NIST

Summary

The Go library filippo.io/edwards25519 in versions 1.1.0 and earlier has a flaw in MultiScalarMult that produces invalid results or undefined behavior when the receiver is not the identity point. Version 1.1.1 fixes the issue.

Risk Assessment

Applications using the advanced MultiScalarMult API may produce incorrect cryptographic results, potentially leading to serious security errors in dependent systems.

Recommendation

Update filippo.io/edwards25519 to version 1.1.1 or later.

Related vulnerabilities

Original NVD description (English source)

filippo.io/edwards25519 is a Go library implementing the edwards25519 elliptic curve with APIs for building cryptographic primitives. In versions 1.1.0 and earlier, MultiScalarMult produces invalid results or undefined behavior if the receiver is not the identity point. If (*Point).MultiScalarMult is called on an initialized point that is not the identity point, it returns an incorrect result. If the method is called on an uninitialized point, the behavior is undefined. In particular, if the receiver is the zero value, MultiScalarMult returns an invalid point that compares Equal to every other point. Note that MultiScalarMult is a rarely used, advanced API. For example, users who depend on filippo.io/edwards25519 only through github.com/go-sql-driver/mysql are not affected. This issue has been fixed in version 1.1.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS