CVE Catalog

CVE-2026-25783

MediumCVSS 4.3
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly validate User-Agent header tokens. An authenticated attacker can cause a request panic via a specially crafted User-Agent header.

Risk Assessment

May lead to denial of service (panic) and destabilization of the Mattermost application by an authenticated user.

Recommendation

Update Mattermost to a fixed version (above 11.3.0, 11.2.2, 10.11.10) per MMSA-2026-00586.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly validate User-Agent header tokens which allows an authenticated attacker to cause a request panic via a specially crafted User-Agent header. Mattermost Advisory ID: MMSA-2026-00586

Vulnerability data from NVD (NIST) · CISA KEV · EPSS