CVE Catalog

CVE-2026-24458

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, and 10.11.x <= 10.11.10 fail to properly handle very long passwords. An attacker can overload server CPU and memory by executing login attempts with multi-megabyte passwords.

Risk Assessment

Potential server resource exhaustion and denial of service for Mattermost users through repeated login attempts with very long passwords.

Recommendation

Update Mattermost to a patched version (later than 11.3.0, 11.2.2, or 10.11.10); consider enforcing password length limits and login rate limiting.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly handle very long passwords, which allows an attacker to overload the server CPU and memory via executing login attempts with multi-megabyte passwords. Mattermost Advisory ID: MMSA-2026-00587

Vulnerability data from NVD (NIST) · CISA KEV · EPSS