CVE-2026-21579
HighCVSS 7.5Exploitation Probability (EPSS)
Low risk38th percentile - higher than 38% of all known CVEs
Summary
Information disclosure vulnerability in Confluence Data Center. An unauthenticated attacker can access sensitive information without authentication.
Risk Assessment
Disclosure of confidential data stored in Confluence, such as passwords, API keys, or customer data, can compromise organizational security and lead to data breaches.
Recommendation
Upgrade Confluence Data Center to version 9.2.22 or later (for 9.2) or 10.2.14 or later (for 10.2).
Other vulnerabilities in Confluence Data Center
See all- CVE-2026-21588High
A High severity Denial of Service (DoS) vulnerability in Confluence Data Center versions 8.9.0, 9.0.1, 9.1.0, 9.2.0, 9.3.1, 9.4.0, 9.5.1, 10.0.2, 10.1.0, and 10.2.0. An authenticated attacker can cause a resource to be unavailable for its intended users by temporarily or indefinitely disrupting services of a host connected to a network.
- CVE-2026-21586High
A High severity Improper Authorization vulnerability in Confluence Data Center versions 7.4.0, 7.13.0, 8.5.0, 8.9.0, 9.0.1, 9.1.0, 9.2.0, 9.3.1, 9.4.0, 9.5.1, 10.0.2, 10.1.0, and 10.2.0. An authenticated attacker can gain unintended access, potentially leading to exposure of resources or functionality, and possibly enabling sensitive information disclosure or arbitrary code execution.
- CVE-2026-21577Medium
High severity DoS vulnerability in Confluence Data Center versions 9.0.1 through 10.2.0. An authenticated attacker can cause temporary or permanent unavailability of resources by disrupting services of a network host.
- CVE-2025-22166High
A high severity DoS (Denial of Service) vulnerability was introduced in version 2.0 of Confluence Data Center. An attacker can cause a resource to be unavailable for its intended users by temporarily or indefinitely disrupting services of a host connected to a network. CVSS score is 8.3.
Original NVD description (English source)
This High severity Information Disclosure vulnerability was introduced in versions 7.17.0, 7.19.0, 8.5.0, 8.9.0, 9.0.1, 9.1.0, 9.2.0, 10.0.2, 10.1.0, and 10.2.0 of Confluence Data Center. This Information Disclosure vulnerability, with a CVSS Score of 8.2, allows an unauthenticated attacker to view sensitive information via an Information Disclosure vulnerability. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center 9.2: Upgrade to a release greater than or equal to 9.2.22 Confluence Data Center 10.2: Upgrade to a release greater than or equal to 10.2.14 See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was reported via our Atlassian (Internal) program.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

