CVE Catalog

CVE-2026-14359

HighCVSS 8.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.25%

16th percentile - higher than 16% of all known CVEs

Summary

The YITH WooCommerce Waitlist Premium plugin for WordPress up to version 3.35.0 is vulnerable to Privilege Escalation. The add_user_in_waiting_list() function lacks capability checks and nonce verification, and uses parse_str() and extract() to import attacker-controlled variables, allowing authenticated attackers with Subscriber-level access to create an administrator account and assign the administrator role.

Risk Assessment

Authenticated attackers with low privileges can gain full control of the site by creating administrator accounts.

Recommendation

Update the plugin to a version newer than 3.35.0 that includes a fix for privilege escalation.

Related vulnerabilities

Original NVD description (English source)

The YITH WooCommerce Waitlist Premium plugin for WordPress is vulnerable to Privilege Escalation in versions up to, and including, 3.35.0. This is due to the add_user_in_waiting_list() function registered on the wp_ajax_yith_wcwtl_add_user action being missing both a capability check and a nonce verification, and using parse_str() + extract() to import attacker-controlled variables from $_POST['params'] that are then passed to wp_create_user() and $user->set_role(). This makes it possible for authenticated attackers, with Subscriber-level access and above, to elevate their privileges to that of an administrator by creating a new user account and assigning it the administrator role.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS