CVE Catalog

CVE-2026-121928

LowCVSS 3.5
Published: Updated: Translated: NVD NIST

Summary

A vulnerability was identified in InfiniFlow RAGFlow up to 0.27.2 affecting some unknown processing of the file api/utils/file_utils.py of the Images API component. The manipulation leads to cross site scripting. The attack can be initiated remotely, and the exploit is publicly available and might be used.

Risk Assessment

A remote attacker can exploit XSS in the Images API component, potentially executing malicious scripts in the user's context. Public exploit availability increases the risk of exploitation.

Recommendation

Upgrade RAGFlow to version 0.27.3, which contains the fix (commit 9ea0246f8d453a144fb4f903d163b2ba6b91ed2c). Upgrading the affected component is advised.

Other vulnerabilities in RAGFlow

See all
Original NVD description (English source)

A vulnerability was identified in InfiniFlow RAGFlow up to 0.27.2. This issue affects some unknown processing of the file api/utils/file_utils.py of the component Images API. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit is publicly available and might be used. Upgrading to version 0.27.3 is capable of addressing this issue. The identifier of the patch is 9ea0246f8d453a144fb4f903d163b2ba6b91ed2c. Upgrading the affected component is advised.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS