CVE Catalog

CVE-2026-121519

MediumCVSS 6.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.22%

12th percentile - higher than 12% of all known CVEs

Summary

The Social Slider Feed plugin for WordPress in versions up to and including 2.3.8 is vulnerable to stored cross-site scripting via the 'slidespeed' parameter. A missing current_user_can() check in the Factory framework's connect() dispatcher allows Subscriber-level users to bypass the manage_options gate and overwrite the slidespeed setting.

Risk Assessment

An authenticated attacker with subscriber-level access can inject arbitrary web scripts that execute on every public page embedding the feed shortcode. This may lead to visitor session theft.

Recommendation

Update the plugin to a version later than 2.3.8. Until then, restrict subscriber roles or disable the feed shortcode.

Other vulnerabilities in Social Slider Feed

Original NVD description (English source)

The Social Slider Feed – Social Media Feed & Gallery Widgets plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'slidespeed' parameter in all versions up to, and including, 2.3.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The missing current_user_can() check in the Factory framework's connect() dispatcher allows Subscriber-level users to bypass the manage_options capability gate and both harvest a valid wis_edit_feed nonce and overwrite any feed's slidespeed setting, after which the stored payload fires on every public pageview embedding the feed shortcode.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS