CVE-2026-119977
HighCVSS 8.1Exploitation Probability (EPSS)
Low risk49th percentile - higher than 49% of all known CVEs
Summary
WordPress Core versions 4.7 through 7.1.3 are vulnerable to Remote Code Execution due to predictable, web-accessible staging paths used during full-package core upgrades. This allows unauthenticated attackers to execute code on the server during the upgrade window.
Risk Assessment
An attacker could take control of the WordPress server, leading to full site compromise and potential data leakage. The risk is high because exploitation requires no authentication and only the presence of an upgrade window.
Recommendation
Update WordPress Core to a version later than 7.1.3 as soon as possible and restrict access to staging directories during upgrades. Consider performing upgrades in a controlled maintenance window and monitor for unusual files in the web root.
Other vulnerabilities in WordPress Core
Original NVD description (English source)
WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

