CVE Catalog

CVE-2026-118780

LowCVSS 3.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.17%

7th percentile - higher than 7% of all known CVEs

Summary

In node-forge prior to 1.4.1, pki.verifyCertificateChain() modified the CA store while testing certificates sharing a subject name. A failed chain verification could permanently remove trusted CA certificates from the store, causing later valid chains to fail.

Risk Assessment

Applications reusing the same CA store may experience persistent certificate verification unavailability after a single failed attempt. This can lead to denial of service for TLS-dependent services.

Recommendation

Update node-forge to version 1.4.1 or later. If updating is not possible, avoid reusing the CA store after a failed chain verification.

Other vulnerabilities in node-forge

See all
Original NVD description (English source)

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, the affected implementation used pki.verifyCertificateChain(), pki.createCaStore(), duplicate subject names to process the relevant input or security decision. node-forge modified the CA store while trying certificates that shared a subject name during pki.verifyCertificateChain(). A failed chain verification could permanently remove trusted CA certificates from the store, causing later valid chains to fail and creating a persistent availability impact for applications that reused the store. This issue is fixed in version 1.4.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS