CVE Catalog

CVE-2026-118761

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.50%

43th percentile - higher than 43% of all known CVEs

Summary

In Kubeflow Pipelines prior to 2.18.0, the API server decompressed uploaded pipeline archives without adequately bounding expanded data while locating or reading the pipeline file. A small ZIP or gzip-compressed tar archive can consume disproportionately large memory and exhaust API-server resources. Multipart pipeline and pipeline-version upload processing performs decompression before namespace authorization, so a reachable caller does not need a successful pipeline-create authorization decision. This is fixed in version 2.18.0.

Risk Assessment

An attacker could exhaust memory and resources of the Kubeflow Pipelines API server, causing denial of service for platform users. The required expansion depends on deployment resource limits and concurrent activity.

Recommendation

Upgrade Kubeflow Pipelines to version 2.18.0 and consider limiting uploaded archive sizes and API server resource limits.

Other vulnerabilities in Kubeflow Pipelines

See all
Original NVD description (English source)

Kubeflow Pipelines enables users to build and deploy portable, scalable machine learning workflows. Prior to 2.18.0, the API server decompressed uploaded pipeline archives without adequately bounding expanded data while locating or reading the pipeline file. A small ZIP or gzip-compressed tar archive can consume disproportionately large memory and exhaust API-server resources. Multipart pipeline and pipeline-version upload processing performs decompression before namespace authorization, so a reachable caller does not need a successful pipeline-create authorization decision. URL-import handlers authorize before fetching and decompressing a remote archive. The amount of expansion required to interrupt service depends on deployment resource limits and concurrent activity, and no specific archive is guaranteed to crash every deployment. This issue is fixed in version 2.18.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS