CVE Catalog

CVE-2026-117346

Low risk· EPSS 10%
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.20%

10th percentile - higher than 10% of all known CVEs

Summary

Bitcoin Core through version 31.1 is vulnerable to a Denial of Service attack via undo files that have no size limit. The lack of size restriction may allow resource exhaustion and node destabilization.

Risk Assessment

Organizations using vulnerable Bitcoin Core versions may be exposed to denial-of-service attacks that can lead to node unavailability and network disruption.

Recommendation

Update Bitcoin Core to a version later than 31.1 (e.g., 31.2 or 32.1) to remove the Denial of Service vulnerability.

Other vulnerabilities in Bitcoin Core

See all
Original NVD description (English source)

Bitcoin Core through 31.1 is vulnerable to Denial of Service via undo files having no size limit

Vulnerability data from NVD (NIST) · CISA KEV · EPSS