CVE Catalog

CVE-2026-112192

MediumCVSS 5.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.37%

30th percentile - higher than 30% of all known CVEs

Summary

MISP contains a vulnerability in the handling of module plugin settings. When rebuilding module-supplied settings for API consumption, the server drops the redacted and cli_only flags declared in the module's configuration metadata, potentially exposing sensitive credentials and bypassing access restrictions.

Risk Assessment

An authenticated user with access to server settings can read sensitive module credentials (e.g., API keys) and modify settings that the module author intended to restrict to CLI-only access.

Recommendation

Upgrade MISP to version 2.5.48 or later, which fixes this vulnerability. Until upgraded, restrict access to server settings to trusted administrators only.

Other vulnerabilities in MISP

See all
Original NVD description (English source)

MISP contains a vulnerability in the handling of module plugin settings. When the server rebuilds module-supplied settings for API consumption, it drops the redacted and cli_only flags that a module declares in its own configuration metadata. As a result: - A module that marks a setting (such as an API key) as redacted still has its value returned in full by the servers/getSetting and servers/serverSettingsEdit endpoints, exposing sensitive credentials to any authenticated user who can read server settings. - A module that marks a setting as cli_only (intended to be editable only via the command-line interface) can still be modified through the web API, bypassing the intended access restriction. An authenticated user with access to server settings can therefore read sensitive module credentials and modify settings that the module author intended to restrict to CLI-only access. Affected: <2.5.48

Vulnerability data from NVD (NIST) · CISA KEV · EPSS