CVE-2026-111075
HighCVSS 8.7Exploitation Probability (EPSS)
Low risk31th percentile - higher than 31% of all known CVEs
Summary
In Eclipse OpenJ9 versions prior to 0.63.0, the JITServer component fails to perform cross-field validation on attacker-controlled _size, _paddingSize, and _dataOffset fields during DataDescriptor message deserialization. An unauthenticated remote attacker can send a crafted network payload that triggers an unsigned integer underflow, resulting in an out-of-bounds heap read and an immediate process crash (SIGSEGV).
Risk Assessment
An unauthenticated remote attacker can crash the JVM process when JITServer is enabled, causing denial of service for the application and dependent services.
Recommendation
Upgrade Eclipse OpenJ9 to version 0.63.0 or later. If JITServer is not used, consider disabling it and restricting network access to the JITServer port.
Other vulnerabilities in Eclipse OpenJ9
See all- CVE-2026-97400Medium
In Eclipse OpenJ9 versions up to 0.63, opening a supplied diagnostic dump bundle with the jdmpview tool or equivalent DTFJ code may cause the analyst's machine to read an arbitrary local file named inside the bundle and send its contents to an arbitrary remote host.
- CVE-2026-16441Critical
In Eclipse OpenJ9 up to version 0.60, when executing class files where a previously concrete superclass method has been recompiled as abstract, execution is incorrectly delegated to an interface default method.
- CVE-2026-16439Critical
Vulnerability in Eclipse OpenJ9 up to version 0.60. Using -Xtrace to trace method arguments can lead to buffer underflow.
- CVE-2026-110938High
In Eclipse OpenJ9 versions up to 0.63.0, the JITServer component is vulnerable to denial of service due to improper boundary checks during protocol message and reply handling. An unauthenticated remote attacker or malicious JITServer can transmit malformed network payloads that cause out-of-bounds heap reads, immediately crashing the JITServer daemon or client JVM process via a segmentation fault (SIGSEGV).
- CVE-2026-111074High
In Eclipse OpenJ9 versions prior to 0.63.0, the JITServer component is vulnerable to a pre-authentication remote denial of service. When processing the initial 4-byte length field of an incoming TCP connection, an integer overflow in `MessageBuffer::computeRequiredCapacity()` causes the receiving compilation worker thread to enter an infinite loop consuming ~100% CPU. An unauthenticated remote attacker can exploit this by opening a small number of crafted TCP connections to exhaust the entire worker thread pool, silently halting compilation services for all connected client JVMs.
- CVE-2026-16440Medium
In Eclipse OpenJ9 versions up to 0.60, a crafted .class file with deeply nested annotations causes a segmentation fault.
Original NVD description (English source)
In Eclipse OpenJ9 versions prior to 0.63.0, the JITServer component fails to perform cross-field validation on attacker-controlled `_size`, `_paddingSize`, and `_dataOffset` fields during `DataDescriptor` message deserialization. An unauthenticated remote attacker can send a crafted network payload that triggers an unsigned integer underflow in `DataDescriptor::getPayloadSize()` and `DataDescriptor::getNextDescriptor()`. This results in an out-of-bounds heap read and an immediate process crash (SIGSEGV), causing a denial of service.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

