CVE-2026-106456
MediumCVSS 4.8Exploitation Probability (EPSS)
Low risk13th percentile - higher than 13% of all known CVEs
Summary
In @backstage/plugin-proxy-backend from 0.5.0 to 0.6.18, inconsistent credential enforcement for overlapping proxy routes allows an unauthenticated caller to reach a nested upstream. Fixed in version 0.6.18.
Risk Assessment
Risk of unauthorized access to internal services through the proxy, potentially leading to data exposure or unauthorized operations.
Recommendation
Upgrade @backstage/plugin-proxy-backend to version 0.6.18 or later and review proxy route configuration to avoid overlaps.
Related vulnerabilities
- CVE-2026-86577Critical
Out-of-bounds write vulnerability in Hitachi JP1 products. It affects JP1/Integrated Management 3 - Manager, JP1/Automatic Job Management System 3 (Manager, Agent, Agent Minimal Edition), and JP1/Base in specific versions. The flaw can cause memory corruption due to writing beyond buffer boundaries.
- CVE-2026-86576Critical
Heap-based buffer overflow vulnerability in Hitachi JP1 products. It affects JP1/Integrated Management 3 - Manager, JP1/Automatic Job Management System 3 (Manager, Agent, Agent Minimal Edition), and JP1/Base in specified version ranges. The flaw can corrupt heap memory.
- CVE-2026-86575Critical
Stack-based buffer overflow vulnerability in Hitachi JP1 products. It affects JP1/Integrated Management 3 - Manager, JP1/Automatic Job Management System 3 (Manager, Agent, Agent Minimal Edition), and JP1/Base in specific versions. The flaw can corrupt stack memory and potentially lead to code execution.
- CVE-2026-86574Critical
Heap-based buffer overflow vulnerability in Hitachi JP1/Base. It affects versions from 11-00 before 12-50-54. The flaw can corrupt heap memory.
- CVE-2026-82122Critical
Stack-based buffer overflow vulnerability in Hitachi HiRDB. It affects HiRDB Server Version 10 (from 10-00 before 10-12-01) and HiRDB Server Version 9 and additional-function variants in specified version ranges. The flaw can corrupt stack memory.
- CVE-2026-82120Critical
Heap-based buffer overflow vulnerability in Hitachi HiRDB. It affects HiRDB Server Version 10 (from 10-00 before 10-12-01) and HiRDB Server Version 9 and additional-function variants in specified version ranges. The flaw can corrupt heap memory.
- CVE-2026-82119Critical
OS command injection vulnerability in Hitachi HiRDB. It affects HiRDB Server Version 10 (from 10-00 before 10-12-01) and HiRDB Server Version 9 and additional-function variants in specified version ranges. The flaw may allow execution of arbitrary commands on the system.
- CVE-2026-82118Critical
Stack-based buffer overflow vulnerability in Hitachi HiRDB. It affects HiRDB Server Version 10 (from 10-00 before 10-12-01) and HiRDB Server Version 9 and additional-function variants in specified version ranges. The flaw can corrupt stack memory.
- CVE-2026-82117Critical
Authentication bypass by spoofing vulnerability in Hitachi HiRDB. It affects HiRDB Server Version 10 (from 10-00 before 10-12-01) and HiRDB Server Version 9 and additional-function variants in specified version ranges. The flaw may allow unauthorized access.
- CVE-2026-82116Critical
Missing authentication for critical function vulnerability in Hitachi HiRDB. It affects HiRDB Server Version 10 (from 10-00 before 10-12-01) and HiRDB Server Version 9 and additional-function variants in specified version ranges. The flaw may allow access to critical functions without authentication.
Original NVD description (English source)
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

