CVE Catalog

CVE-2026-102090

MediumCVSS 4.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.20%

9th percentile - higher than 9% of all known CVEs

Summary

Kiteworks Core before version 9.5.1 is vulnerable to Content Injection. A URL parameter in the PDF viewer was insufficiently validated, allowing an attacker-controlled document to be loaded and displayed under the trust of the legitimate application domain. This could increase the credibility of phishing attempts relying on malicious links embedded in the displayed content.

Risk Assessment

Phishing risk: users may trust malicious content displayed in a trusted domain, potentially leading to data theft or infection.

Recommendation

Update Kiteworks Core to version 9.5.1 or later, which properly validates URL parameters in the PDF viewer.

Other vulnerabilities in Kiteworks Core

See all
Original NVD description (English source)

Kiteworks Core before version 9.5.1 is vulnerable to Content Injection. A URL parameter in the PDF viewer was insufficiently validated, allowing an attacker-controlled document to be loaded and displayed under the trust of the legitimate application domain. This could increase the credibility of phishing attempts relying on malicious links embedded in the displayed content.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS