CVE Catalog

CVE-2025-9081

LowCVSS 3.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.28%

19th percentile - higher than 19% of all known CVEs

Summary

Mattermost versions 10.5.x <= 10.5.8 and 9.11.x <= 9.11.17 fail to properly validate access controls, allowing any authenticated user to download sensitive files via the board file download endpoint using UUID enumeration.

Risk Assessment

An authenticated user may access confidential files they are not authorized to view, resulting in a confidentiality breach.

Recommendation

Update Mattermost to a version later than 10.5.8 or 9.11.17 and restrict access to the board file download endpoint.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate access controls which allows any authenticated user to download sensitive files via board file download endpoint using UUID enumeration

Vulnerability data from NVD (NIST) · CISA KEV · EPSS