CVE-2025-69534
HighCVSS 7.5Exploitation Probability (EPSS)
Low risk45th percentile - higher than 45% of all known CVEs
Summary
Python-Markdown version 3.8 contains a vulnerability where malformed HTML-like sequences cause html.parser.HTMLParser to raise an unhandled AssertionError during Markdown parsing. Because Python-Markdown does not catch this exception, any application processing attacker-controlled Markdown may crash.
Risk Assessment
The risk is a remote, unauthenticated Denial of Service (DoS) in web applications, documentation systems, CI/CD pipelines, and any service rendering untrusted Markdown. Uncaught exceptions may also lead to Information Disclosure.
Recommendation
Immediately upgrade Python-Markdown to version 3.8.1 or later, which includes a fix for this vulnerability.
Other vulnerabilities in Python-Markdown
Original NVD description (English source)
Python-Markdown version 3.8 contain a vulnerability where malformed HTML-like sequences can cause html.parser.HTMLParser to raise an unhandled AssertionError during Markdown parsing. Because Python-Markdown does not catch this exception, any application that processes attacker-controlled Markdown may crash. This enables remote, unauthenticated Denial of Service in web applications, documentation systems, CI/CD pipelines, and any service that renders untrusted Markdown. The issue was acknowledged by the vendor and fixed in version 3.8.1. This issue causes a remote Denial of Service in any application parsing untrusted Markdown, and can lead to Information Disclosure through uncaught exceptions.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

