CVE Catalog

CVE-2025-67344

MediumCVSS 4.6
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.17%

6th percentile - higher than 6% of all known CVEs

Summary

jshERP v3.5 and earlier is affected by a stored Cross Site Scripting (XSS) vulnerability via the /msg/add endpoint. The malicious script is stored on the server and executed in the user's browser.

Risk Assessment

An attacker can execute arbitrary JavaScript in the context of other users' sessions, potentially leading to credential theft or account takeover. The risk affects all users viewing the infected messages.

Recommendation

Upgrade jshERP to a version later than 3.5 if available, and implement input validation and sanitization on the /msg/add endpoint. Consider deploying a Content-Security-Policy header to limit script execution.

Other vulnerabilities in jshERP

See all
Original NVD description (English source)

jshERP v3.5 and earlier is affected by a stored Cross Site Scripting (XSS) vulnerability via the /msg/add endpoint.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS