CVE Catalog

CVE-2025-67341

MediumCVSS 4.6
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.17%

6th percentile - higher than 6% of all known CVEs

Summary

jshERP versions 3.5 and earlier are affected by a stored XSS vulnerability. This vulnerability allows attackers to upload PDF files containing XSS payloads, which can then be accessed via static URLs by all users.

Risk Assessment

Malicious PDF files can be rendered to all system users, enabling JavaScript execution in their browsers. This may lead to session theft or other attacks within the application context.

Recommendation

Upgrade jshERP to a version later than 3.5 if available, and implement validation and sanitization of uploaded PDF files. Restrict access to static files and consider serving them with a Content-Disposition: attachment header.

Other vulnerabilities in jshERP

See all
Original NVD description (English source)

jshERP versions 3.5 and earlier are affected by a stored XSS vulnerability. This vulnerability allows attackers to upload PDF files containing XSS payloads. Additionally, these PDF files can be accessed via static URLs, making them accessible to all users.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS