CVE Catalog

CVE-2025-66040

LowCVSS 3.6
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.16%

4th percentile - higher than 4% of all known CVEs

Summary

Spotipy, a Python library for the Spotify Web API, prior to version 2.25.2 contains a cross-site scripting (XSS) vulnerability in the OAuth callback server. The unsanitized error parameter allows JavaScript injection, enabling attackers to execute arbitrary JavaScript in the user's browser during OAuth authentication.

Risk Assessment

An attacker can execute malicious JavaScript in the context of the user's browser during OAuth authorization, potentially leading to token or session data theft.

Recommendation

Update Spotipy to version 2.25.2 or later, which contains the fix for this vulnerability.

Related vulnerabilities

Original NVD description (English source)

Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS