CVE Catalog

CVE-2025-65713

MediumCVSS 4.0
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.41%

35th percentile - higher than 35% of all known CVEs

Summary

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Risk Assessment

An attacker may potentially access files outside the intended directory, leading to disclosure or overwriting of sensitive data in the Home Assistant installation.

Recommendation

Update Home Assistant Core to version 2025.8.0 or later. Until then, limit use of the Downloader integration and review the paths being supplied.

Other vulnerabilities in Home Assistant Core

See all
Original NVD description (English source)

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS