CVE Catalog

CVE-2025-64747

MediumCVSS 5.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.26%

17th percentile - higher than 17% of all known CVEs

Summary

Directus versions prior to 11.13.0 contain a stored cross-site scripting (XSS) vulnerability. Users with upload files and edit item permissions can inject malicious JavaScript through the Block Editor interface, bypassing Content Security Policy (CSP) by combining file uploads with iframe srcdoc attributes. The issue is fixed in version 11.13.0.

Risk Assessment

An attacker can execute persistent script in a victim's browser, hijack sessions, or perform actions on their behalf. The risk affects organizations where many users have content editing permissions.

Recommendation

Update Directus to version 11.13.0 or later. Restrict upload files and edit item permissions to trusted users.

Other vulnerabilities in Directus

See all
Original NVD description (English source)

Directus is a real-time API and App dashboard for managing SQL database content. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 11.13.0 that allows users with `upload files` and `edit item` permissions to inject malicious JavaScript through the Block Editor interface. Attackers can bypass Content Security Policy (CSP) restrictions by combining file uploads with iframe srcdoc attributes, resulting in persistent XSS execution. Version 11.13.0 fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS