CVE Catalog

CVE-2025-64460

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
2.09%

81th percentile - higher than 81% of all known CVEs

Summary

In Django 5.2 before 5.2.9, 5.1 before 5.1.15, and 4.2 before 4.2.27, algorithmic complexity in django.core.serializers.xml_serializer.getInnerText() allows a remote attacker to cause a denial-of-service via CPU and memory exhaustion using specially crafted XML input processed by the XML Deserializer.

Risk Assessment

An attacker can remotely exhaust server resources and cause unavailability of Django applications that process untrusted XML.

Recommendation

Upgrade Django to 5.2.9, 5.1.15, or 4.2.27 (or later) and avoid processing untrusted XML through the deserializer.

Other vulnerabilities in Django

See all
Original NVD description (English source)

An issue was discovered in 5.2 before 5.2.9, 5.1 before 5.1.15, and 4.2 before 4.2.27. Algorithmic complexity in `django.core.serializers.xml_serializer.getInnerText()` allows a remote attacker to cause a potential denial-of-service attack triggering CPU and memory exhaustion via specially crafted XML input processed by the XML `Deserializer`. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Seokchan Yoon for reporting this issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS