CVE Catalog

CVE-2025-63749

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.98%

62th percentile - higher than 62% of all known CVEs

Summary

pnetlab 5.3.11 is vulnerable to command injection via the qemu_options parameter. The vulnerability allows injection and execution of arbitrary system commands.

Risk Assessment

An attacker could execute arbitrary commands on the system, potentially leading to environment compromise, data theft, or further privilege escalation.

Recommendation

Update pnetlab to a version later than 5.3.11 if a patch is available. Until then, restrict access to the management interface and validate the qemu_options parameter input.

Other vulnerabilities in pnetlab

See all
Original NVD description (English source)

pnetlab 5.3.11 is vulnerable to Command Injection via the qemu_options parameter.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS