CVE Catalog

CVE-2025-59940

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.34%

26th percentile - higher than 26% of all known CVEs

Summary

The mkdocs-include-markdown-plugin for Mkdocs in versions 7.1.7 and below has a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.

Risk Assessment

An attacker can exploit the collision of input with placeholders to manipulate documentation content or inject unexpected data.

Recommendation

Update the plugin to version 7.1.8 or later.

Related vulnerabilities

Original NVD description (English source)

mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS