CVE-2025-59454
MediumCVSS 4.3Exploitation Probability (EPSS)
Low risk28th percentile - higher than 28% of all known CVEs
Summary
In Apache CloudStack, a gap in access control checks affected the APIs createNetworkACL, listNetworkACLs, listResourceDetails, listVirtualMachinesUsageHistory, and listVolumesUsageHistory. While these APIs were accessible only to authorized users, insufficient permission validation meant that users could occasionally access information beyond their intended scope. Users are recommended to upgrade to Apache CloudStack 4.20.2.0 or 4.22.0.0.
Risk Assessment
Users with limited privileges may access information beyond their role, potentially leading to data leakage. This may compromise confidentiality and system integrity.
Recommendation
Upgrade Apache CloudStack to version 4.20.2.0 or 4.22.0.0, which fix the issue. Review and adjust user permissions to minimize risk.
Other vulnerabilities in Apache CloudStack
See all- CVE-2026-62440Critical
Improper Access Control vulnerability in Apache CloudStack's Kubernetes Service (CKS) plugin, allowing cross-tenant manipulation of the Kubernetes cluster while adding and removing nodes. Affects versions from 4.21.0.0 through 4.22.1.0.
- CVE-2026-61398Critical
Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's UI while using Instance Reset Password functionality. Affects versions from 4.15.1.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
- CVE-2026-59085Critical
Server-Side Request Forgery (SSRF) vulnerability in Apache CloudStack's webhook module, exploitable via webhook delivery requests. Affects versions from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
- CVE-2026-25199Critical
In the Proxmox extension for Apache CloudStack, a non-privileged user can modify the proxmox_vmid setting to reference a VM belonging to another tenant. This allows unauthorized cross-tenant access and full control over the targeted VM, including starting, stopping, and destroying it.
- CVE-2015-3252Critical
Apache CloudStack before version 4.5.2 does not properly preserve VNC passwords when migrating KVM virtual machines, allowing remote attackers to gain access by connecting to the VNC server.
- CVE-2026-59654High
Apache CloudStack versions 4.7.0 through 4.20.3.0 and 4.21.0.0 through 4.22.1.0 have a missing release of resource after effective lifetime vulnerability in the scoped global configuration functionality. This may lead to denial of service (DoS) for the management server.
- CVE-2026-68745High
Certificate validation failures in SAML authentication in Apache CloudStack 4.20.3.0 and 4.22.1.0 allow a malicious agent to forge a SAML response to the management server. The agent must spoof the IdP IP address or register a URL of its own choosing, after which it can allow logging on with forged signatures. Users are recommended to upgrade to versions 4.20.3.1 or 4.22.1.1 and above.
- CVE-2026-66797Medium
Improper access control in CloudStack's annotation functionality allows unauthorized comment creation and disclosure. The addAnnotation and listAnnotation APIs perform an ownership check but fail to honor its result correctly, allowing any authenticated user to write and read annotations on entities they don't own. Affects versions from 4.15.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
- CVE-2026-66722High
Improper authorization for CRUD operations on Project Roles and Project Role permissions for domain admins in CloudStack. A Domain Admin can create, update, delete, and list project roles and permissions for projects in any domain, not just their own. Affects versions from 4.15.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
- CVE-2026-66721Low
Missing authorization issue for domain admins in CloudStack's host tags listing functionality. Domain Admins have permission to call listHostTags API, but it returns host tags for every host without domain scoping. Affects versions from 4.12.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
Original NVD description (English source)
In Apache CloudStack, a gap in access control checks affected the APIs - createNetworkACL - listNetworkACLs - listResourceDetails - listVirtualMachinesUsageHistory - listVolumesUsageHistory While these APIs were accessible only to authorized users, insufficient permission validation meant that users could occasionally access information beyond their intended scope. Users are recommended to upgrade to Apache CloudStack 4.20.2.0 or 4.22.0.0, which fixes the issue.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

