CVE Catalog

CVE-2025-59163

LowCVSS 2.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.41%

33th percentile - higher than 33% of all known CVEs

Summary

The vet tool (versions 1.12.4 and below) is vulnerable to a DNS rebinding attack due to lack of HTTP Host and Origin header validation. Data from the vet scan sqlite3 database may be exposed to remote attackers when vet is used as an MCP server in SSE mode with default ports through the sqlite3 query MCP tool.

Risk Assessment

A remote attacker can access sensitive data from the vet scanner database, potentially leading to leakage of software supply chain information.

Recommendation

Update vet to version 1.12.5, which fixes this vulnerability.

Related vulnerabilities

Original NVD description (English source)

vet is an open source software supply chain security tool. Versions 1.12.4 and below are vulnerable to a DNS rebinding attack due to lack of HTTP Host and Origin header validation. Data from the vet scan sqlite3 database may be exposed to remote attackers when vet is used as an MCP server in SSE mode with default ports through the sqlite3 query MCP tool. This issue is fixed in version 1.12.5.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS