CVE-2025-58674
MediumCVSS 5.9Exploitation Probability (EPSS)
Low risk11th percentile - higher than 11% of all known CVEs
Summary
WordPress versions from 4.7 through 6.8.2 are vulnerable to stored XSS due to improper neutralization of input during web page generation. The vulnerability requires Author or higher privileges to exploit.
Risk Assessment
A user with Author privileges can inject a malicious script that executes in other users' browsers, potentially leading to session hijacking.
Recommendation
Monitor WordPress updates and apply the fix as soon as it becomes available. Limit the number of users with Author privileges to the necessary minimum.
Other vulnerabilities in WordPress
See all- CVE-2012-6707High
WordPress through version 4.8.2 uses a weak MD5-based password hashing algorithm, making it easier for attackers to determine cleartext values by leveraging access to the hash values.
- CVE-2017-9066High
In WordPress before version 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF vulnerability.
- CVE-2017-9065High
In WordPress before version 4.7.5, there is a lack of capability checks for post meta data in the XML-RPC API.
- CVE-2017-9064High
In WordPress before version 4.7.5, a Cross Site Request Forgery (CSRF) vulnerability exists in the filesystem credentials dialog because a nonce is not required for updating credentials.
- CVE-2017-9062High
In WordPress before version 4.7.5, there is improper handling of post meta data values in the XML-RPC API.
- CVE-2016-6896High
A directory traversal vulnerability in the wp_ajax_update_plugin function in WordPress 4.5.3 allows remote authenticated users to cause a denial of service or read certain text files via a .. (dot dot) in the plugin parameter to wp-admin/admin-ajax.php.
- CVE-2017-5489High
The CSRF vulnerability in WordPress before version 4.7.1 allows remote attackers to hijack the authentication of unspecified victims via vectors involving Flash file uploads.
- CVE-2016-4029High
WordPress before 4.5 does not consider octal and hexadecimal IP address formats when determining an intranet address, which allows remote attackers to bypass an intended SSRF protection mechanism via a crafted address.
- CVE-2016-5839High
WordPress versions before 4.5.3 allow remote attackers to bypass the sanitize_file_name protection mechanism via unspecified vectors.
- CVE-2016-5838High
WordPress before 4.5.3 allows remote attackers to bypass intended password-change restrictions by leveraging knowledge of a cookie.
Original NVD description (English source)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WordPress allows Stored XSS. WordPress core security team is aware of the issue and working on a fix. This is low severity vulnerability that requires an attacker to have Author or higher user privileges to execute the attack vector.This issue affects WordPress: from 6.8 through 6.8.2, from 6.7 through 6.7.3, from 6.6 through 6.6.3, from 6.5 through 6.5.6, from 6.4 through 6.4.6, from 6.3 through 6.3.6, from 6.2 through 6.2.7, from 6.1 through 6.1.8, from 6.0 through 6.0.10, from 5.9 through 5.9.11, from 5.8 through 5.8.11, from 5.7 through 5.7.13, from 5.6 through 5.6.15, from 5.5 through 5.5.16, from 5.4 through 5.4.17, from 5.3 through 5.3.19, from 5.2 through 5.2.22, from 5.1 through 5.1.20, from 5.0 through 5.0.23, from 4.9 through 4.9.27, from 4.8 through 4.8.26, from 4.7 through 4.7.30.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

