CVE Catalog

CVE-2025-58057

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.63%

49th percentile - higher than 49% of all known CVEs

Summary

A vulnerability in Netty's decompression decoders, including BrotliDecoder, allows specially crafted input to allocate a large number of reachable byte buffers, potentially leading to denial of service. Decompression lacks a limit on pull calls, processing data in 64K chunks, and buffers remain reachable until OOM occurs.

Risk Assessment

A remote attacker could cause a denial of service by sending crafted data to applications using vulnerable Netty versions, potentially making the service unavailable.

Recommendation

Update netty-codec to version 4.1.125.Final or later and netty-codec-compression to version 4.2.5.Final or later.

Other vulnerabilities in Netty

See all
Original NVD description (English source)

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS