CVE Catalog

CVE-2025-57807

LowCVSS 3.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.29%

20th percentile - higher than 20% of all known CVEs

Summary

ImageMagick versions lower than 14.8.2 include insecure functions SeekBlob() and WriteBlob() that allow a heap write beyond the allocated memory when the offset is large. The vulnerability does not require external delegates or policy settings. It is fixed in version 14.8.2.

Risk Assessment

An attacker could cause memory corruption, potentially leading to arbitrary code execution or application crash. This requires processing a specially crafted image.

Recommendation

Update ImageMagick to version 14.8.2 or later. Until then, avoid processing untrusted images and consider restricting privileges of image processing processes.

Other vulnerabilities in ImageMagick

See all
Original NVD description (English source)

ImageMagick is free and open-source software used for editing and manipulating digital images. ImageMagick versions lower than 14.8.2 include insecure functions: SeekBlob(), which permits advancing the stream offset beyond the current end without increasing capacity, and WriteBlob(), which then expands by quantum + length (amortized) instead of offset + length, and copies to data + offset. When offset ≫ extent, the copy targets memory beyond the allocation, producing a deterministic heap write on 64-bit builds. No 2⁶⁴ arithmetic wrap, external delegates, or policy settings are required. This is fixed in version 14.8.2.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS