CVE Catalog

CVE-2025-55073

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.20%

9th percentile - higher than 9% of all known CVEs

Summary

Mattermost versions 10.11.x through 10.11.3, 10.5.x through 10.5.11, and 10.12.x through 10.12.0 fail to validate the relationship between the post being updated and the MSTeams plugin OAuth flow. This allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL.

Risk Assessment

An attacker can modify other users' post content, impersonating or misleading them. This affects the integrity of organizational communication.

Recommendation

Update Mattermost to a version later than 10.11.3, 10.5.11, or 10.12.0. Review the MSTeams plugin configuration.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to validate the relationship between the post being updated and the MSTeams plugin OAuth flow which allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS