CVE Catalog

CVE-2025-53092

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.29%

20th percentile - higher than 20% of all known CVEs

Summary

Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the Origin header value in the Access-Control-Allow-Origin response header without proper validation or whitelisting, allowing an attacker-controlled site to send credentialed requests to the Strapi backend. The vulnerability is fixed in version 5.20.0.

Risk Assessment

An attacker can host a malicious site on a different origin and send authenticated requests to the Strapi API, potentially performing actions on behalf of a logged-in user. This can lead to data disclosure or modification.

Recommendation

Update Strapi to version 5.20.0 or later. Until updated, configure an explicit whitelist of allowed origins in CORS settings.

Other vulnerabilities in Strapi

See all
Original NVD description (English source)

Strapi is an open source headless content management system. Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the value of the Origin header back in the Access-Control-Allow-Origin response header without proper validation or whitelisting. This allows an attacker-controlled site to send credentialed requests to the Strapi backend. An attacker can exploit this by hosting a malicious site on a different origin (e.g., different port) and sending requests with credentials to the Strapi API. The vulnerability is fixed in version 5.20.0. No known workarounds exist.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS