CVE Catalog

CVE-2025-23050

LowCVSS 3.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.19%

8th percentile - higher than 8% of all known CVEs

Summary

QLowEnergyController in Qt before 6.8.2 mishandles malformed Bluetooth ATT commands, leading to an out-of-bounds read (or division by zero). The vulnerability is fixed in versions 5.15.19, 6.5.9, and 6.8.2.

Risk Assessment

The vulnerability may lead to information disclosure, application crash, or potential code execution in the process context. However, it requires access to the Bluetooth interface.

Recommendation

Update Qt to version 5.15.19, 6.5.9, or 6.8.2 (or later). Avoid using vulnerable versions in production environments.

Other vulnerabilities in Qt

See all
Original NVD description (English source)

QLowEnergyController in Qt before 6.8.2 mishandles malformed Bluetooth ATT commands, leading to an out-of-bounds read (or division by zero). This is fixed in 5.15.19, 6.5.9, and 6.8.2.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS