CVE Catalog

CVE-2025-20621

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, and 10.1.x <= 10.1.3 fail to properly handle posts with attachments containing fields that cannot be cast to a String. An attacker can cause the webapp to crash by creating and sending such a post to a channel.

Risk Assessment

An attacker can cause the webapp to crash, causing temporary unavailability of the interface for users.

Recommendation

Update Mattermost to a patched version (e.g., 10.2.1, 9.11.6, 10.0.4, 10.1.4 or later).

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly handle posts with attachments containing fields that cannot be cast to a String, which allows an attacker to cause the webapp to crash via creating and sending such a post to a channel.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS