CVE-2025-15453
MediumCVSS 6.3Exploitation Probability (EPSS)
Low risk27th percentile - higher than 27% of all known CVEs
Summary
A security vulnerability was detected in milvus up to 2.6.7, affecting the function expr.Exec in the file pkg/util/expr/expr.go of the HTTP Endpoint component. Manipulation of the code argument leads to deserialization, and remote exploitation is possible.
Risk Assessment
A remote attacker can exploit deserialization to perform unauthorized operations, potentially leading to system compromise. The exploit has been publicly disclosed and may be used.
Recommendation
Plan to update to version 2.6.8 when available, and in the meantime restrict access to the HTTP endpoint and monitor for suspicious requests.
Other vulnerabilities in milvus
Original NVD description (English source)
A security vulnerability has been detected in milvus up to 2.6.7. This vulnerability affects the function expr.Exec of the file pkg/util/expr/expr.go of the component HTTP Endpoint. The manipulation of the argument code leads to deserialization. Remote exploitation of the attack is possible. The exploit has been disclosed publicly and may be used. A fix is planned for the next release 2.6.8.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

