CVE Catalog

CVE-2025-14284

MediumCVSS 6.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.37%

29th percentile - higher than 29% of all known CVEs

Summary

Versions of the package @tiptap/extension-link before 2.10.4 are vulnerable to Cross-site Scripting (XSS) due to unsanitized user input allowed in setting or toggling links. An attacker can execute arbitrary JavaScript code in the context of the application by injecting a javascript: URL payload into these attributes, which is then triggered by user interaction.

Risk Assessment

This allows an attacker to execute malicious code in the victim's browser, potentially leading to session theft, data exfiltration, or account takeover.

Recommendation

Update @tiptap/extension-link to version 2.10.4 or later and implement input validation and sanitization in the application.

Related vulnerabilities

Original NVD description (English source)

Versions of the package @tiptap/extension-link before 2.10.4 are vulnerable to Cross-site Scripting (XSS) due to unsanitized user input allowed in setting or toggling links. An attacker can execute arbitrary JavaScript code in the context of the application by injecting a javascript: URL payload into these attributes, which is then triggered either by user interaction.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS