CVE Catalog

CVE-2025-1412

LowCVSS 3.1
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 9.11.x <= 9.11.6 and 10.4.x <= 10.4.1 fail to invalidate all active sessions when converting a user to a bot. This allows the converted user to escalate their privileges depending on the permissions granted to the bot.

Risk Assessment

A user converted to a bot may retain active sessions and gain higher privileges than intended, potentially leading to unauthorized access to resources. Organizations using Mattermost are exposed to privilege escalation within the platform.

Recommendation

Update Mattermost to a version later than 9.11.6 or 10.4.1. After updating, review and if necessary invalidate active sessions of users converted to bots.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 9.11.x <= 9.11.6, 10.4.x <= 10.4.1 fail to invalidate all active sessions when converting a user to a bot, with allows the converted user to escalate their privileges depending on the permissions granted to the bot.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS