CVE Catalog

CVE-2025-13378

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.29%

20th percentile - higher than 20% of all known CVEs

Summary

The AI ChatBot with ChatGPT and Content Generator by AYS plugin for WordPress in all versions up to and including 2.7.0 is vulnerable to Server-Side Request Forgery via the ays_chatgpt_pinecone_upsert function. This allows unauthenticated attackers to make web requests to arbitrary locations from the application server and to query and modify information from internal services.

Risk Assessment

An unauthenticated attacker can use the WordPress server to scan the internal network and interact with internal services, potentially leading to data disclosure or modification. The risk is high in environments with access to internal APIs.

Recommendation

Update the plugin to a version later than 2.7.0 if available, or disable it. Restrict outbound network connections from the WordPress server and segment the network.

Other vulnerabilities in AI ChatBot with ChatGPT and Content Generator by AYS

Original NVD description (English source)

The AI ChatBot with ChatGPT and Content Generator by AYS plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.7.0 via the ays_chatgpt_pinecone_upsert function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS