CVE-2025-12483
MediumCVSS 6.5Exploitation Probability (EPSS)
Low risk21th percentile - higher than 21% of all known CVEs
Summary
The Visualizer: Tables and Charts Manager for WordPress plugin in versions up to and including 3.11.12 is vulnerable to SQL Injection via the 'query' parameter due to insufficient escaping and lack of query preparation. Authenticated attackers with Contributor-level access or higher can append additional SQL queries to extract sensitive information from the database. Version 3.11.13 raises the minimum user level to administrator, and 3.11.14 fully patches the vulnerability.
Risk Assessment
This may lead to unauthorized access to database data, including user and configuration data, by low-privileged users.
Recommendation
Update the Visualizer plugin to version 3.11.14 or later, which fully patches the vulnerability.
Other vulnerabilities in Visualizer
See all- CVE-2026-86784Medium
The Visualizer WordPress plugin before 4.0.8 does not sanitise and escape a chart's JSON data source configuration before outputting it back in the chart editor. Users with the Contributor role and above can store JavaScript that executes in the browser of any higher-privileged user, such as an administrator, who reviews the affected chart.
- CVE-2026-86782Medium
The Visualizer WordPress plugin before 4.0.6 does not properly authorise access to its chart-building actions, allowing users with the Contributor role and above to publish, rename, and overwrite the content of posts and pages they do not own, including other users' private drafts.
- CVE-2026-19726Medium
The Visualizer WordPress plugin before 4.0.7 does not properly authorize access to chart configuration, allowing users with the Contributor role and above to read the full configuration of any chart on the site, including charts the plugin's interface denies them, and to retrieve every chart's configuration in a single request. The disclosed configuration can include credentials of a remote data source.
- CVE-2026-65526High
The Visualizer WordPress plugin (versions up to and including 4.0.1) has a blind SQL Injection vulnerability due to improper neutralization of special elements in SQL commands.
- CVE-2026-24573Medium
The WordPress plugin Visualizer before version 4.0.0 contains a Stored Cross-Site Scripting (XSS) vulnerability due to improper neutralization of input during web page generation.
Original NVD description (English source)
The Visualizer: Tables and Charts Manager for WordPress plugin for WordPress is vulnerable to SQL Injection via the 'query' parameter in all versions up to, and including, 3.11.12 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Version 3.11.13 raises the minimum user-level for exploitation to administrator. 3.11.14 fully patches the vulnerability.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

