CVE Catalog

CVE-2025-12060

HighCVSS 8.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.63%

49th percentile - higher than 49% of all known CVEs

Summary

The keras.utils.get_file API in Keras, when used with the extract=True option for tar archives, is vulnerable to a path traversal attack. The utility uses Python's tarfile.extractall function without the filter="data" feature, allowing a remote attacker to craft a malicious tar archive containing special symlinks and write arbitrary files to any location on the filesystem. This vulnerability is linked to CVE-2025-4517 in Python, but upgrading Python alone is not enough—Keras must also be upgraded to version 3.12.

Risk Assessment

An attacker can overwrite critical system or application files, potentially leading to code execution or data destruction.

Recommendation

Update Keras to version 3.12 or later and consider updating Python to a version that fixes CVE-2025-4517 (e.g., 3.13.4).

Other vulnerabilities in Keras

See all
Original NVD description (English source)

The keras.utils.get_file API in Keras, when used with the extract=True option for tar archives, is vulnerable to a path traversal attack. The utility uses Python's tarfile.extractall function without the filter="data" feature. A remote attacker can craft a malicious tar archive containing special symlinks, which, when extracted, allows them to write arbitrary files to any location on the filesystem outside of the intended destination folder. This vulnerability is linked to the underlying Python tarfile weakness, identified as CVE-2025-4517. Note that upgrading Python to one of the versions that fix CVE-2025-4517 (e.g. Python 3.13.4) is not enough. One additionally needs to upgrade Keras to a version with the fix (Keras 3.12).

Vulnerability data from NVD (NIST) · CISA KEV · EPSS