CVE-2024-47401
MediumCVSS 4.3Summary
Mattermost versions 9.10.x <= 9.10.2, 9.11.x <= 9.11.1 and 9.5.x <= 9.5.9 fail to prevent detailed error messages from being displayed in Playbooks. An attacker can send a specially crafted request to Playbooks to generate a large response and cause an amplified GraphQL response, potentially crashing the application.
Risk Assessment
Potential remote Denial of Service by an attacker with access to Playbooks, disrupting teams using Mattermost.
Recommendation
Update Mattermost to a version later than 9.10.2, 9.11.1 or 9.5.9 as recommended by the vendor. Consider restricting Playbooks access for untrusted users.
Other vulnerabilities in Mattermost Playbooks
Original NVD description (English source)
Mattermost versions 9.10.x <= 9.10.2, 9.11.x <= 9.11.1 and 9.5.x <= 9.5.9 fail to prevent detailed error messages from being displayed in Playbooks which allows an attacker to generate a large response and cause an amplified GraphQL response which in turn could cause the application to crash by sending a specially crafted request to Playbooks.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

