CVE Catalog

CVE-2024-47003

LowCVSS 3.1
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 9.11.x <= 9.11.0 and 9.5.x <= 9.5.8 fail to validate that the message of the permalink post is a string, allowing an attacker to send a non-string value as the message of a permalink post and crash the frontend.

Risk Assessment

This can lead to denial of service by crashing the Mattermost user interface.

Recommendation

Update Mattermost to a version later than 9.11.0 or 9.5.8.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 9.11.x <= 9.11.0 and 9.5.x <= 9.5.8 fail to validate that the message of the permalink post is a string, which allows an attacker to send a non-string value as the message of a permalink post and crash the frontend.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS