CVE Catalog

CVE-2024-41144

MediumCVSS 5.5
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, and 9.8.x <= 9.8.1 fail to properly validate synced posts when shared channels are enabled. A malicious remote can create, update, or delete arbitrary posts in arbitrary channels.

Risk Assessment

Integrity breach — a malicious remote can modify or delete posts in arbitrary channels, causing disinformation or data destruction. This may undermine trust in communication.

Recommendation

Update Mattermost to a patched version (above 9.9.0, 9.5.6, 9.7.5, or 9.8.1). Consider limiting trust in remote servers in shared channels.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, 9.8.x <= 9.8.1 fail to properly validate synced posts, when shared channels are enabled,  which allows a malicious remote to create/update/delete arbitrary posts in arbitrary channels

Vulnerability data from NVD (NIST) · CISA KEV · EPSS