CVE Catalog

CVE-2024-10214

LowCVSS 3.5
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 9.11.X <= 9.11.1 and 9.5.x <= 9.5.9 incorrectly issues two sessions when using desktop SSO — one in the browser and one in the desktop app with incorrect settings.

Risk Assessment

Improper session handling may lead to authentication security issues and potential unauthorized access.

Recommendation

Update Mattermost to a version later than 9.11.1 or 9.5.9. Review SSO configuration for the desktop app.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 9.11.X <= 9.11.1, 9.5.x <= 9.5.9 icorrectly issues two sessions when using desktop SSO - one in the browser and one in desktop with incorrect settings.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS